cve.bz

CVE-2025-32421

3.7 lowEPSS 0.8%

Low (3.7) in vercel next.js. EPSS 0.8% chance of exploitation in the next 30 days. Fixed in next 14.2.24, 15.1.6.

Next.js is a React framework for building full-stack web applications. Versions prior to 14.2.24 and 15.1.6 have a race-condition vulnerability. This issue only affects the Pages Router under certain misconfigurations, causing normal endpoints to serve `pageProps` data instead of standard HTML. This issue was patched in versions 15.1.6 and 14.2.24 by stripping the `x-now-route-matches` header from incoming requests. Applications hosted on Vercel's platform are not affected by this issue, as the platform does not cache responses based solely on `200 OK` status without explicit `cache-control` headers. Those who self-host Next.js deployments and are unable to upgrade immediately can mitigate this vulnerability by stripping the `x-now-route-matches` header from all incoming requests at the content development network and setting `cache-control: no-store` for all responses under risk. The maintainers of Next.js strongly recommend only caching responses with explicit cache-control headers.

Severity

CVSS 3.1

3.7 low
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
0.8% chance of exploitation in the next 30 days; higher than 56% of CVEs (scores of 2026-11-01)
CWE
CWE-362
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qpjv-v59x-3qc4npmnext>=0.9.9 <14.2.2414.2.24
GHSA-qpjv-v59x-3qc4npmnext>=15.0.0 <15.1.615.1.6

References

Check your stackJSON