cve.bz

CVE-2025-24970

7.5 highEPSS 2.2%

High (7.5). EPSS 2.2% chance of exploitation in the next 30 days. Fixed in io.netty:netty-handler 4.1.118.Final.

Netty, an asynchronous, event-driven network application framework, has a vulnerability starting in version 4.1.91.Final and prior to version 4.1.118.Final. When a special crafted packet is received via SslHandler it doesn't correctly handle validation of such a packet in all cases which can lead to a native crash. Version 4.1.118.Final contains a patch. As workaround its possible to either disable the usage of the native SSLEngine or change the code manually.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
2.2% chance of exploitation in the next 30 days; higher than 82% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-4g8c-wm8x-jfhwMavenio.netty:netty-handler>=4.1.91.Final <4.1.118.Final4.1.118.Final

References

Check your stackJSON