cve.bz

CVE-2024-53983

5.4 mediumEPSS 0.4%

Medium (5.4). EPSS 0.4% chance of exploitation in the next 30 days. Fixed in @backstage/plugin-scaffolder-node 0.4.12, 0.5.1, 0.6.1.

The Backstage Scaffolder plugin Houses types and utilities for building scaffolder-related modules. A vulnerability is identified in Backstage Scaffolder template functionality where Server-Side Template Injection (SSTI) can be exploited to perform Git config injection. The vulnerability allows an attacker to capture privileged git tokens used by the Backstage Scaffolder plugin. With these tokens, unauthorized access to sensitive resources in git can be achieved. The impact is considered medium severity as the Backstage Threat Model recommends restricting access to adding and editing templates in the Backstage Catalog plugin. The issue has been resolved in versions `v0.4.12`, `v0.5.1` and `v0.6.1` of the `@backstage/plugin-scaffolder-node` package. Users are encouraged to upgrade to this version to mitigate the vulnerability. Users are advised to upgrade. Users unable to upgrade may ensure that templates do not change git config.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:N/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 31% of CVEs (scores of 2026-10-31)
CWE
CWE-918
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qmc2-jpr5-7rg9npm@backstage/plugin-scaffolder-node<0.4.120.4.12
GHSA-qmc2-jpr5-7rg9npm@backstage/plugin-scaffolder-node>=0.5.0 <0.5.10.5.1
GHSA-qmc2-jpr5-7rg9npm@backstage/plugin-scaffolder-node>=0.6.0 <0.6.10.6.1

References

Check your stackJSON