cve.bz

CVE-2024-53900

9.1 criticalEPSS 4.0%

Critical (9.1) in mongoosejs mongoose. EPSS 4.0% chance of exploitation in the next 30 days. Fixed in mongoose 5.13.23, 6.13.5, 7.8.3.

Mongoose before 8.8.3 can improperly use $where in match, leading to search injection.

Severity

CVSS 3.1

9.1 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
4.0% chance of exploitation in the next 30 days; higher than 90% of CVEs (scores of 2026-10-31)
CWE
CWE-89
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-m7xq-9374-9rvxnpmmongoose>=8.0.0-rc0 <8.8.38.8.3
GHSA-m7xq-9374-9rvxnpmmongoose>=7.0.0-rc0 <7.8.37.8.3
GHSA-m7xq-9374-9rvxnpmmongoose>=6.0.0-rc0 <6.13.56.13.5
GHSA-m7xq-9374-9rvxnpmmongoose>=3.6.0-rc0 <5.13.235.13.23

References

Check your stackJSON