cve.bz

CVE-2024-49375

9.0 criticalEPSS 0.9%

Critical (9.0). EPSS 0.9% chance of exploitation in the next 30 days. Fixed in rasa-pro 3.10.12, 3.8.18, 3.9.16.

Open source machine learning framework. A vulnerability has been identified in Rasa that enables an attacker who has the ability to load a maliciously crafted model remotely into a Rasa instance to achieve Remote Code Execution. The prerequisites for this are: 1. The HTTP API must be enabled on the Rasa instance eg with `--enable-api`. This is not the default configuration. 2. For unauthenticated RCE to be exploitable, the user must not have configured any authentication or other security controls recommended in our documentation. 3. For authenticated RCE, the attacker must posses a valid authentication token or JWT to interact with the Rasa API. This issue has been addressed in rasa version 3.6.21 and all users are advised to upgrade. Users unable to upgrade should ensure that they require authentication and that only trusted users are given access.

Severity

CVSS 3.1

9.0 critical
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
0.9% chance of exploitation in the next 30 days; higher than 60% of CVEs (scores of 2026-10-31)
CWEs
CWE-94, CWE-502
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-cpv4-ggrr-7j9vPyPIrasa-pro>=3.10.0 <3.10.123.10.12
GHSA-cpv4-ggrr-7j9vPyPIrasa-pro>=3.9.0 <3.9.163.9.16
GHSA-cpv4-ggrr-7j9vPyPIrasa-pro<3.8.183.8.18
GHSA-cpv4-ggrr-7j9vPyPIrasa<3.6.213.6.21
PYSEC-2026-513PyPIrasa<3.6.213.6.21
PYSEC-2026-514PyPIrasa-pro<3.8.183.8.18

References

Check your stackJSON