cve.bz

CVE-2024-45613

5.1 mediumEPSS 0.5%

Medium (5.1) in ckeditor ckeditor5. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in ckeditor5 43.1.1.

CKEditor 5 is a JavaScript rich-text editor. Starting in version 40.0.0 and prior to version 43.1.1, a Cross-Site Scripting (XSS) vulnerability is present in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability only affects installations where the Block Toolbar plugin is enabled and either the General HTML Support (with a configuration that permits unsafe markup) or the HTML Embed plugin is also enabled. A fix for the problem is available in version 43.1.1. As a workaround, one may disable the block toolbar plugin.

Severity

CVSS 4.0

5.1 medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

CVSS 3.1

6.1 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
0.5% chance of exploitation in the next 30 days; higher than 44% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-rgg8-g5x8-wr9vnpmckeditor5>=40.0.0 <43.1.143.1.1
GHSA-rgg8-g5x8-wr9vnpm@ckeditor/ckeditor5-clipboard>=40.0.0 <43.1.143.1.1

References

Check your stackJSON