cve.bz

CVE-2024-45033

8.1 highEPSS 1.0%

High (8.1) in apache apache-airflow-providers-fab. EPSS 1.0% chance of exploitation in the next 30 days. Fixed in apache-airflow-providers-fab 1.5.2.

Insufficient Session Expiration vulnerability in Apache Airflow Fab Provider. This issue affects Apache Airflow Fab Provider: before 1.5.2. When user password has been changed with admin CLI, the sessions for that user have not been cleared, leading to insufficient session expiration, thus logged users could continue to be logged in even after the password was changed. This only happened when the password was changed with CLI. The problem does not happen in case change was done with webserver thus this is different from  CVE-2023-40273 https://github.com/advisories/GHSA-pm87-24wq-r8w9  which was addressed in Apache-Airflow 2.7.0 Users are recommended to upgrade to version 1.5.2, which fixes the issue.

Severity

CVSS 3.1

8.1 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
1.0% chance of exploitation in the next 30 days; higher than 62% of CVEs (scores of 2026-10-31)
CWE
CWE-613
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-8863-4qmg-fr45PyPIapache-airflow-providers-fab<1.5.21.5.2
PYSEC-2026-1147PyPIapache-airflow-providers-fab<1.5.21.5.2

References

Check your stackJSON