{"cve":"CVE-2024-45033","nvd":{"published":"2025-01-08T09:15:07.290","modified":"2026-06-17T07:53:27.760","status":"Analyzed","description":"Insufficient Session Expiration vulnerability in Apache Airflow Fab Provider.\n\nThis issue affects Apache Airflow Fab Provider: before 1.5.2.\n\nWhen user password has been changed with admin CLI, the sessions for that user have not been cleared, leading to insufficient session expiration, thus logged users could continue to be logged in even after the password was changed. This only happened when the password was changed with CLI. The problem does not happen in case change was done with webserver thus this is different from  CVE-2023-40273 https://github.com/advisories/GHSA-pm87-24wq-r8w9  which was addressed in Apache-Airflow 2.7.0\n\n\nUsers are recommended to upgrade to version 1.5.2, which fixes the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","score":8.1},"cwes":["CWE-613"],"references":["https://github.com/apache/airflow/pull/45139","https://lists.apache.org/thread/yw535346rk766ybzpqtvrl36sjj789st"],"products":["apache:apache-airflow-providers-fab"],"source":"nvd","synced_at":"2026-10-19T21:58:20.756570362+00:00"},"epss":{"cve":"CVE-2024-45033","score":0.00988,"percentile":0.62487,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-8863-4qmg-fr45","url":"https://osv.dev/vulnerability/GHSA-8863-4qmg-fr45","summary":"Apache Airflow Fab Provider Insufficient Session Expiration vulnerability","modified":"2026-09-10T03:50:56.295660992Z","packages":[{"ecosystem":"PyPI","name":"apache-airflow-providers-fab","purl":"pkg:pypi/apache-airflow-providers-fab","ranges":["<1.5.2"],"fixed":["1.5.2"]}]},{"id":"PYSEC-2026-1147","url":"https://osv.dev/vulnerability/PYSEC-2026-1147","summary":"Apache Airflow Fab Provider Insufficient Session Expiration vulnerability","modified":"2026-07-07T17:46:27.186860131Z","packages":[{"ecosystem":"PyPI","name":"apache-airflow-providers-fab","purl":"pkg:pypi/apache-airflow-providers-fab","ranges":["<1.5.2"],"fixed":["1.5.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}