cve.bz

CVE-2024-40635

7.8 highEPSS 0.3%

High (7.8). EPSS 0.3% chance of exploitation in the next 30 days. Fixed in github.com/containerd/containerd/v2 2.0.4.

containerd is an open-source container runtime. A bug was found in containerd prior to versions 1.6.38, 1.7.27, and 2.0.4 where containers launched with a User set as a `UID:GID` larger than the maximum 32-bit signed integer can cause an overflow condition where the container ultimately runs as root (UID 0). This could cause unexpected behavior for environments that require containers to run as a non-root user. This bug has been fixed in containerd 1.6.38, 1.7.27, and 2.04. As a workaround, ensure that only trusted images are used and that only trusted users have permissions to import images.

Severity

CVSS 3.1

7.8 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.3% chance of exploitation in the next 30 days; higher than 23% of CVEs (scores of 2026-10-31)
CWE
CWE-190
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-265r-hfxg-fhmgGogithub.com/containerd/containerd/v2<2.0.42.0.4
GHSA-265r-hfxg-fhmgGogithub.com/containerd/containerd>=1.7.0-beta.0 <1.7.271.7.27
GHSA-265r-hfxg-fhmgGogithub.com/containerd/containerd<1.6.381.6.38
GO-2025-3528Gogithub.com/containerd/containerd<1.6.38
>=1.7.0-beta.0 <1.7.27
1.6.38, 1.7.27
GO-2025-3528Gogithub.com/containerd/containerd/v2<2.0.42.0.4

References

Check your stackJSON