{"cve":"CVE-2024-40635","nvd":{"published":"2025-03-17T22:15:13.150","modified":"2026-06-17T07:46:12.817","status":"Analyzed","description":"containerd is an open-source container runtime. A bug was found in containerd prior to versions 1.6.38, 1.7.27, and 2.0.4 where containers launched with a User set as a `UID:GID` larger than the maximum 32-bit signed integer can cause an overflow condition where the container ultimately runs as root (UID 0). This could cause unexpected behavior for environments that require containers to run as a non-root user. This bug has been fixed in containerd 1.6.38, 1.7.27, and 2.04. As a workaround, ensure that only trusted images are used and that only trusted users have permissions to import images.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":7.8},"cwes":["CWE-190"],"references":["https://github.com/containerd/containerd/commit/05044ec0a9a75232cad458027ca83437aae3f4da","https://github.com/containerd/containerd/commit/1a43cb6a1035441f9aca8f5666a9b3ef9e70ab20","https://github.com/containerd/containerd/commit/cf158e884cfe4812a6c371b59e4ea9bc4c46e51a","https://github.com/containerd/containerd/security/advisories/GHSA-265r-hfxg-fhmg","https://lists.debian.org/debian-lts-announce/2025/05/msg00005.html"],"products":["debian:debian_linux","linuxfoundation:containerd"],"source":"nvd","synced_at":"2026-10-19T22:00:17.429720821+00:00"},"epss":{"cve":"CVE-2024-40635","score":0.00304,"percentile":0.23227,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-265r-hfxg-fhmg","url":"https://osv.dev/vulnerability/GHSA-265r-hfxg-fhmg","summary":"containerd has an integer overflow in User ID handling","modified":"2026-09-10T03:50:06.145474067Z","packages":[{"ecosystem":"Go","name":"github.com/containerd/containerd/v2","purl":"pkg:golang/github.com/containerd/containerd/v2","ranges":["<2.0.4"],"fixed":["2.0.4"]},{"ecosystem":"Go","name":"github.com/containerd/containerd","purl":"pkg:golang/github.com/containerd/containerd","ranges":[">=1.7.0-beta.0 <1.7.27"],"fixed":["1.7.27"]},{"ecosystem":"Go","name":"github.com/containerd/containerd","purl":"pkg:golang/github.com/containerd/containerd","ranges":["<1.6.38"],"fixed":["1.6.38"]}]},{"id":"GO-2025-3528","url":"https://osv.dev/vulnerability/GO-2025-3528","summary":"containerd has an integer overflow in User ID handling in github.com/containerd/containerd","modified":"2026-02-04T03:50:47.304274Z","packages":[{"ecosystem":"Go","name":"github.com/containerd/containerd","purl":"pkg:golang/github.com/containerd/containerd","ranges":["<1.6.38",">=1.7.0-beta.0 <1.7.27"],"fixed":["1.6.38","1.7.27"]},{"ecosystem":"Go","name":"github.com/containerd/containerd/v2","purl":"pkg:golang/github.com/containerd/containerd/v2","ranges":["<2.0.4"],"fixed":["2.0.4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}