cve.bz

CVE-2024-39309

9.8 criticalEPSS 20%

Critical (9.8). EPSS 20% chance of exploitation in the next 30 days. Fixed in parse-server 6.5.7, 7.1.0.

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. A vulnerability in versions prior to 6.5.7 and 7.1.0 allows SQL injection when Parse Server is configured to use the PostgreSQL database. The algorithm to detect SQL injection has been improved in versions 6.5.7 and 7.1.0. No known workarounds are available.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
20% chance of exploitation in the next 30 days; higher than 97% of CVEs (scores of 2026-10-31)
CWEs
CWE-89, CWE-288
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-c2hr-cqg6-8j6rnpmparse-server<6.5.76.5.7
GHSA-c2hr-cqg6-8j6rnpmparse-server>=7.0.0 <7.1.07.1.0

References

Check your stackJSON