cve.bz

CVE-2024-38357

6.1 mediumEPSS 0.5%

Medium (6.1). EPSS 0.5% chance of exploitation in the next 30 days. Fixed in tinymce 5.11.0, 6.8.4, 7.2.0.

TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content parsing code. This allowed specially crafted noscript elements containing malicious code to be executed when that content was loaded into the editor. This vulnerability has been patched in TinyMCE 7.2.0, TinyMCE 6.8.4 and TinyMCE 5.11.0 LTS by ensuring that content within noscript elements are properly parsed. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Severity

CVSS 3.1

6.1 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
0.5% chance of exploitation in the next 30 days; higher than 44% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-w9jx-4g6g-rp7xnpmtinymce<5.11.05.11.0
GHSA-w9jx-4g6g-rp7xNuGetTinyMCE<5.11.05.11.0
GHSA-w9jx-4g6g-rp7xPackagisttinymce/tinymce<5.11.05.11.0
GHSA-w9jx-4g6g-rp7xnpmtinymce>=6.0.0 <6.8.46.8.4
GHSA-w9jx-4g6g-rp7xnpmtinymce>=7.0.0 <7.2.07.2.0
GHSA-w9jx-4g6g-rp7xNuGetTinyMCE>=6.0.0 <6.8.46.8.4
GHSA-w9jx-4g6g-rp7xNuGetTinyMCE>=7.0.0 <7.2.07.2.0
GHSA-w9jx-4g6g-rp7xPackagisttinymce/tinymce>=6.0.0 <6.8.46.8.4
GHSA-w9jx-4g6g-rp7xPackagisttinymce/tinymce>=7.0.0 <7.2.07.2.0
GHSA-w9jx-4g6g-rp7xPyPIdjango-tinymce<4.1.04.1.0
PYSEC-2026-1302PyPIdjango-tinymce<4.1.04.1.0

References

Check your stackJSON