{"cve":"CVE-2024-38357","nvd":{"published":"2024-06-19T20:15:11.727","modified":"2026-06-17T07:39:59.210","status":"Deferred","description":"TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content parsing code. This allowed specially crafted noscript elements containing malicious code to be executed when that content was loaded into the editor. This vulnerability has been patched in TinyMCE 7.2.0, TinyMCE 6.8.4 and TinyMCE 5.11.0 LTS by ensuring that content within noscript elements are properly parsed. Users are advised to upgrade. There are no known workarounds for this vulnerability.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/tinymce/tinymce/commit/5acb741665a98e83d62b91713c800abbff43b00d","https://github.com/tinymce/tinymce/security/advisories/GHSA-w9jx-4g6g-rp7x","https://owasp.org/www-community/attacks/xss","https://www.tiny.cloud/docs/tinymce/6/6.8.4-release-notes/#overview","https://www.tiny.cloud/docs/tinymce/7/7.2-release-notes/#overview"],"products":[],"source":"nvd","synced_at":"2026-10-19T21:52:00.836172422+00:00"},"epss":{"cve":"CVE-2024-38357","score":0.00529,"percentile":0.44778,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-w9jx-4g6g-rp7x","url":"https://osv.dev/vulnerability/GHSA-w9jx-4g6g-rp7x","summary":"TinyMCE Cross-Site Scripting (XSS) vulnerability using noscript elements","modified":"2026-09-10T03:50:17.091452211Z","packages":[{"ecosystem":"npm","name":"tinymce","purl":"pkg:npm/tinymce","ranges":["<5.11.0"],"fixed":["5.11.0"]},{"ecosystem":"NuGet","name":"TinyMCE","purl":"pkg:nuget/TinyMCE","ranges":["<5.11.0"],"fixed":["5.11.0"]},{"ecosystem":"Packagist","name":"tinymce/tinymce","purl":"pkg:composer/tinymce/tinymce","ranges":["<5.11.0"],"fixed":["5.11.0"]},{"ecosystem":"npm","name":"tinymce","purl":"pkg:npm/tinymce","ranges":[">=6.0.0 <6.8.4"],"fixed":["6.8.4"]},{"ecosystem":"npm","name":"tinymce","purl":"pkg:npm/tinymce","ranges":[">=7.0.0 <7.2.0"],"fixed":["7.2.0"]},{"ecosystem":"NuGet","name":"TinyMCE","purl":"pkg:nuget/TinyMCE","ranges":[">=6.0.0 <6.8.4"],"fixed":["6.8.4"]},{"ecosystem":"NuGet","name":"TinyMCE","purl":"pkg:nuget/TinyMCE","ranges":[">=7.0.0 <7.2.0"],"fixed":["7.2.0"]},{"ecosystem":"Packagist","name":"tinymce/tinymce","purl":"pkg:composer/tinymce/tinymce","ranges":[">=6.0.0 <6.8.4"],"fixed":["6.8.4"]},{"ecosystem":"Packagist","name":"tinymce/tinymce","purl":"pkg:composer/tinymce/tinymce","ranges":[">=7.0.0 <7.2.0"],"fixed":["7.2.0"]},{"ecosystem":"PyPI","name":"django-tinymce","purl":"pkg:pypi/django-tinymce","ranges":["<4.1.0"],"fixed":["4.1.0"]}]},{"id":"PYSEC-2026-1302","url":"https://osv.dev/vulnerability/PYSEC-2026-1302","summary":"TinyMCE Cross-Site Scripting (XSS) vulnerability using noscript elements","modified":"2026-07-07T17:46:38.052584330Z","packages":[{"ecosystem":"PyPI","name":"django-tinymce","purl":"pkg:pypi/django-tinymce","ranges":["<4.1.0"],"fixed":["4.1.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}