cve.bz

CVE-2024-28098

5.4 mediumEPSS 1.7%

Medium (5.4) in apache pulsar. EPSS 1.7% chance of exploitation in the next 30 days. Fixed in org.apache.pulsar:pulsar-broker 2.10.6, 2.11.4, 3.0.3.

The vulnerability allows authenticated users with only produce or consume permissions to modify topic-level policies, such as retention, TTL, and offloading settings. These management operations should be restricted to users with the tenant admin role or super user role. This issue affects Apache Pulsar versions from 2.7.1 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Apache Pulsar users should upgrade to at least 2.10.6. 2.11 Apache Pulsar users should upgrade to at least 2.11.4. 3.0 Apache Pulsar users should upgrade to at least 3.0.3. 3.1 Apache Pulsar users should upgrade to at least 3.1.3. 3.2 Apache Pulsar users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
1.7% chance of exploitation in the next 30 days; higher than 77% of CVEs (scores of 2026-10-31)
CWE
CWE-863
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-g627-r579-rw35Mavenorg.apache.pulsar:pulsar-broker>=3.2.0 <3.2.13.2.1
GHSA-g627-r579-rw35Mavenorg.apache.pulsar:pulsar-broker>=3.1.0 <3.1.33.1.3
GHSA-g627-r579-rw35Mavenorg.apache.pulsar:pulsar-broker>=3.0.0 <3.0.33.0.3
GHSA-g627-r579-rw35Mavenorg.apache.pulsar:pulsar-broker>=2.11.0 <2.11.42.11.4
GHSA-g627-r579-rw35Mavenorg.apache.pulsar:pulsar-broker>=2.7.1 <2.10.62.10.6

References

Check your stackJSON