{"cve":"CVE-2024-28098","nvd":{"published":"2024-03-12T19:15:48.177","modified":"2026-06-17T07:20:57.897","status":"Modified","description":"The vulnerability allows authenticated users with only produce or consume permissions to modify topic-level policies, such as retention, TTL, and offloading settings. These management operations should be restricted to users with the tenant admin role or super user role.\n\nThis issue affects Apache Pulsar versions from 2.7.1 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. \n\n2.10 Apache Pulsar users should upgrade to at least 2.10.6.\n2.11 Apache Pulsar users should upgrade to at least 2.11.4.\n3.0 Apache Pulsar users should upgrade to at least 3.0.3.\n3.1 Apache Pulsar users should upgrade to at least 3.1.3.\n3.2 Apache Pulsar users should upgrade to at least 3.2.1.\n\nUsers operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","score":5.4},"cwes":["CWE-863"],"references":["http://www.openwall.com/lists/oss-security/2024/03/12/12","https://lists.apache.org/thread/3m6923y3wxpdcs9346sjvt8ql9swqc2z","https://pulsar.apache.org/security/CVE-2024-28098/","http://www.openwall.com/lists/oss-security/2024/03/12/12","https://lists.apache.org/thread/3m6923y3wxpdcs9346sjvt8ql9swqc2z"],"products":["apache:pulsar"],"source":"nvd","synced_at":"2026-10-19T21:46:54.846886191+00:00"},"epss":{"cve":"CVE-2024-28098","score":0.01701,"percentile":0.77222,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-g627-r579-rw35","url":"https://osv.dev/vulnerability/GHSA-g627-r579-rw35","summary":"Apache Pulsar: Improper Authorization For Topic-Level Policy Management","modified":"2025-02-13T19:13:53.063180Z","packages":[{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-broker","purl":"pkg:maven/org.apache.pulsar/pulsar-broker","ranges":[">=3.2.0 <3.2.1"],"fixed":["3.2.1"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-broker","purl":"pkg:maven/org.apache.pulsar/pulsar-broker","ranges":[">=3.1.0 <3.1.3"],"fixed":["3.1.3"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-broker","purl":"pkg:maven/org.apache.pulsar/pulsar-broker","ranges":[">=3.0.0 <3.0.3"],"fixed":["3.0.3"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-broker","purl":"pkg:maven/org.apache.pulsar/pulsar-broker","ranges":[">=2.11.0 <2.11.4"],"fixed":["2.11.4"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-broker","purl":"pkg:maven/org.apache.pulsar/pulsar-broker","ranges":[">=2.7.1 <2.10.6"],"fixed":["2.10.6"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}