cve.bz

CVE-2024-27135

9.9 criticalEPSS 6.0%

Critical (9.9) in apache pulsar. EPSS 6.0% chance of exploitation in the next 30 days. Fixed in org.apache.pulsar:pulsar-functions-worker 2.10.6, 2.11.4, 3.0.3.

Improper input validation in the Pulsar Function Worker allows a malicious authenticated user to execute arbitrary Java code on the Pulsar Function worker, outside of the sandboxes designated for running user-provided functions. This vulnerability also applies to the Pulsar Broker when it is configured with "functionsWorkerEnabled=true". This issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.6. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.4. 3.0 Pulsar Function Worker users should upgrade to at least 3.0.3. 3.1 Pulsar Function Worker users should upgrade to at least 3.1.3. 3.2 Pulsar Function Worker users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Severity

CVSS 3.1

9.9 critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
6.0% chance of exploitation in the next 30 days; higher than 93% of CVEs (scores of 2026-10-31)
CWEs
CWE-20, CWE-913
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-xp2r-g8qq-44hhMavenorg.apache.pulsar:pulsar-functions-worker>=2.4.0 <2.10.62.10.6
GHSA-xp2r-g8qq-44hhMavenorg.apache.pulsar:pulsar-functions-worker>=2.11.0 <2.11.42.11.4
GHSA-xp2r-g8qq-44hhMavenorg.apache.pulsar:pulsar-functions-worker>=3.0.0 <3.0.33.0.3
GHSA-xp2r-g8qq-44hhMavenorg.apache.pulsar:pulsar-functions-worker>=3.1.0 <3.1.33.1.3
GHSA-xp2r-g8qq-44hhMavenorg.apache.pulsar:pulsar-functions-worker>=3.2.0 <3.2.13.2.1

References

Check your stackJSON