{"cve":"CVE-2024-27135","nvd":{"published":"2024-03-12T19:15:47.567","modified":"2026-06-17T07:19:13.653","status":"Modified","description":"Improper input validation in the Pulsar Function Worker allows a malicious authenticated user to execute arbitrary Java code on the Pulsar Function worker, outside of the sandboxes designated for running user-provided functions. This vulnerability also applies to the Pulsar Broker when it is configured with \"functionsWorkerEnabled=true\".\n\nThis issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. \n\n2.10 Pulsar Function Worker users should upgrade to at least 2.10.6.\n2.11 Pulsar Function Worker users should upgrade to at least 2.11.4.\n3.0 Pulsar Function Worker users should upgrade to at least 3.0.3.\n3.1 Pulsar Function Worker users should upgrade to at least 3.1.3.\n3.2 Pulsar Function Worker users should upgrade to at least 3.2.1.\n\nUsers operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","score":9.9},"cwes":["CWE-20","CWE-913"],"references":["http://www.openwall.com/lists/oss-security/2024/03/12/9","https://lists.apache.org/thread/dh8nj2vmb2br6thjltq74lk9jxkz62wn","https://pulsar.apache.org/security/CVE-2024-27135/","http://www.openwall.com/lists/oss-security/2024/03/12/9","https://lists.apache.org/thread/dh8nj2vmb2br6thjltq74lk9jxkz62wn"],"products":["apache:pulsar"],"source":"nvd","synced_at":"2026-10-19T21:46:54.846886191+00:00"},"epss":{"cve":"CVE-2024-27135","score":0.05983,"percentile":0.93308,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-xp2r-g8qq-44hh","url":"https://osv.dev/vulnerability/GHSA-xp2r-g8qq-44hh","summary":"Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution","modified":"2025-02-13T19:36:18.647646Z","packages":[{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-functions-worker","purl":"pkg:maven/org.apache.pulsar/pulsar-functions-worker","ranges":[">=2.4.0 <2.10.6"],"fixed":["2.10.6"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-functions-worker","purl":"pkg:maven/org.apache.pulsar/pulsar-functions-worker","ranges":[">=2.11.0 <2.11.4"],"fixed":["2.11.4"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-functions-worker","purl":"pkg:maven/org.apache.pulsar/pulsar-functions-worker","ranges":[">=3.0.0 <3.0.3"],"fixed":["3.0.3"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-functions-worker","purl":"pkg:maven/org.apache.pulsar/pulsar-functions-worker","ranges":[">=3.1.0 <3.1.3"],"fixed":["3.1.3"]},{"ecosystem":"Maven","name":"org.apache.pulsar:pulsar-functions-worker","purl":"pkg:maven/org.apache.pulsar/pulsar-functions-worker","ranges":[">=3.2.0 <3.2.1"],"fixed":["3.2.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}