cve.bz

CVE-2024-26149

5.3 mediumEPSS 0.5%

Medium (5.3) in vyperlang vyper. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in vyper 0.4.0, 0.4.0b1.

Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. If an excessively large value is specified as the starting index for an array in `_abi_decode`, it can cause the read position to overflow. This results in the decoding of values outside the intended array bounds, potentially leading to exploitations in contracts that use arrays within `_abi_decode`. This vulnerability affects 0.3.10 and earlier versions.

Severity

CVSS 3.1

5.3 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
0.5% chance of exploitation in the next 30 days; higher than 45% of CVEs (scores of 2026-10-31)
CWE
CWE-119
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-9p8r-4xp4-gw5wPyPIvyper<0.4.00.4.0
PYSEC-2024-164PyPIvyper<0.4.0b10.4.0b1

References

Check your stackJSON