cve.bz

CVE-2024-26016

5.4 mediumEPSS 0.9%

Medium (5.4) in apache superset. EPSS 0.9% chance of exploitation in the next 30 days. Fixed in apache-superset 3.0.4, 3.1.1.

A low privilege authenticated user could import an existing dashboard or chart that they do not have access to and then modify its metadata, thereby gaining ownership of the object. However, it's important to note that access to the analytical data of these charts and dashboards would still be subject to validation based on data access privileges. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.Users are recommended to upgrade to version 3.1.1, which fixes the issue.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
0.9% chance of exploitation in the next 30 days; higher than 58% of CVEs (scores of 2026-10-31)
CWE
CWE-863
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-3v9r-885j-762gPyPIapache-superset<3.0.43.0.4
GHSA-3v9r-885j-762gPyPIapache-superset>=3.1.0 <3.1.13.1.1
PYSEC-2026-1158PyPIapache-superset<3.0.4
>=3.1.0 <3.1.1
3.0.4, 3.1.1

References

Check your stackJSON