{"cve":"CVE-2024-26016","nvd":{"published":"2024-02-28T12:15:47.850","modified":"2026-06-17T07:16:55.860","status":"Modified","description":"A low privilege authenticated user could import an existing dashboard or chart that they do not have access to and then modify its metadata, thereby gaining ownership of the object. However, it's important to note that access to the analytical data of these charts and dashboards would still be subject to validation based on data access privileges.\n\nThis issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.Users are recommended to upgrade to version 3.1.1, which fixes the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","score":5.4},"cwes":["CWE-863"],"references":["http://www.openwall.com/lists/oss-security/2024/02/28/7","https://lists.apache.org/thread/76v1jjcylgk4p3m0258qr359ook3vl8s","http://www.openwall.com/lists/oss-security/2024/02/28/7","https://lists.apache.org/thread/76v1jjcylgk4p3m0258qr359ook3vl8s"],"products":["apache:superset"],"source":"nvd","synced_at":"2026-10-19T21:45:59.823092188+00:00"},"epss":{"cve":"CVE-2024-26016","score":0.00873,"percentile":0.58927,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-3v9r-885j-762g","url":"https://osv.dev/vulnerability/GHSA-3v9r-885j-762g","summary":"Apache Superset: Improper authorization validation on dashboards and charts import","modified":"2026-07-07T17:56:51.292327560Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":["<3.0.4"],"fixed":["3.0.4"]},{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":[">=3.1.0 <3.1.1"],"fixed":["3.1.1"]}]},{"id":"PYSEC-2026-1158","url":"https://osv.dev/vulnerability/PYSEC-2026-1158","summary":"Apache Superset: Improper authorization validation on dashboards and charts import","modified":"2026-07-07T17:56:51.292327560Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":["<3.0.4",">=3.1.0 <3.1.1"],"fixed":["3.0.4","3.1.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}