cve.bz

CVE-2024-25621

7.8 highEPSS 0.2%

High (7.8) in linuxfoundation containerd. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in github.com/containerd/containerd 1.7.29.

containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths `/var/lib/containerd`, `/run/containerd/io.containerd.grpc.v1.cri` and `/run/containerd/io.containerd.sandbox.controller.v1.shim` were all created with incorrect permissions. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. Workarounds include updating system administrator permissions so the host can manually chmod the directories to not have group or world accessible permissions, or to run containerd in rootless mode.

Severity

CVSS 3.1

7.8 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 6% of CVEs (scores of 2026-10-31)
CWE
CWE-279
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pwhc-rpq9-4c8wGogithub.com/containerd/containerd<1.7.291.7.29
GHSA-pwhc-rpq9-4c8wGogithub.com/containerd/containerd/v2<2.0.72.0.7
GHSA-pwhc-rpq9-4c8wGogithub.com/containerd/containerd/v2>=2.1.0-beta.0 <2.1.52.1.5
GHSA-pwhc-rpq9-4c8wGogithub.com/containerd/containerd/v2>=2.2.0-beta.0 <2.2.02.2.0
GO-2025-4100Gogithub.com/containerd/containerd<1.7.291.7.29
GO-2025-4100Gogithub.com/containerd/containerd/v2<2.0.7
>=2.1.0-beta.0 <2.1.5
>=2.2.0-beta.0 <2.2.0
2.0.7, 2.1.5, 2.2.0

References

Check your stackJSON