{"cve":"CVE-2024-25621","nvd":{"published":"2025-11-06T19:15:40.090","modified":"2026-06-17T07:16:18.617","status":"Analyzed","description":"containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths `/var/lib/containerd`, `/run/containerd/io.containerd.grpc.v1.cri` and `/run/containerd/io.containerd.sandbox.controller.v1.shim` were all created with incorrect permissions. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. Workarounds include updating system administrator permissions so the host can manually chmod the directories to not have group or world accessible permissions, or to run containerd in rootless mode.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":7.8},"cwes":["CWE-279"],"references":["https://github.com/containerd/containerd/blob/main/docs/rootless.md","https://github.com/containerd/containerd/commit/7c59e8e9e970d38061a77b586b23655c352bfec5","https://github.com/containerd/containerd/security/advisories/GHSA-pwhc-rpq9-4c8w"],"products":["linuxfoundation:containerd"],"source":"nvd","synced_at":"2026-10-19T22:14:53.307938015+00:00"},"epss":{"cve":"CVE-2024-25621","score":0.00168,"percentile":0.0612,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-pwhc-rpq9-4c8w","url":"https://osv.dev/vulnerability/GHSA-pwhc-rpq9-4c8w","summary":"containerd affected by a local privilege escalation via wide permissions on CRI directory","modified":"2026-09-10T03:50:58.430975281Z","packages":[{"ecosystem":"Go","name":"github.com/containerd/containerd","purl":"pkg:golang/github.com/containerd/containerd","ranges":["<1.7.29"],"fixed":["1.7.29"]},{"ecosystem":"Go","name":"github.com/containerd/containerd/v2","purl":"pkg:golang/github.com/containerd/containerd/v2","ranges":["<2.0.7"],"fixed":["2.0.7"]},{"ecosystem":"Go","name":"github.com/containerd/containerd/v2","purl":"pkg:golang/github.com/containerd/containerd/v2","ranges":[">=2.1.0-beta.0 <2.1.5"],"fixed":["2.1.5"]},{"ecosystem":"Go","name":"github.com/containerd/containerd/v2","purl":"pkg:golang/github.com/containerd/containerd/v2","ranges":[">=2.2.0-beta.0 <2.2.0"],"fixed":["2.2.0"]}]},{"id":"GO-2025-4100","url":"https://osv.dev/vulnerability/GO-2025-4100","summary":"containerd affected by a local privilege escalation via wide permissions on CRI directory in github.com/containerd/containerd","modified":"2026-02-04T02:51:07.565822Z","packages":[{"ecosystem":"Go","name":"github.com/containerd/containerd","purl":"pkg:golang/github.com/containerd/containerd","ranges":["<1.7.29"],"fixed":["1.7.29"]},{"ecosystem":"Go","name":"github.com/containerd/containerd/v2","purl":"pkg:golang/github.com/containerd/containerd/v2","ranges":["<2.0.7",">=2.1.0-beta.0 <2.1.5",">=2.2.0-beta.0 <2.2.0"],"fixed":["2.0.7","2.1.5","2.2.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}