cve.bz

CVE-2024-24773

6.5 mediumEPSS 0.8%

Medium (6.5) in apache superset. EPSS 0.8% chance of exploitation in the next 30 days. Fixed in apache-superset 3.0.4, 3.1.1.

Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1, which fixes the issue.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
0.8% chance of exploitation in the next 30 days; higher than 55% of CVEs (scores of 2026-10-31)
CWE
CWE-863
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-5474-f7g5-273qPyPIapache-superset<3.0.43.0.4
GHSA-5474-f7g5-273qPyPIapache-superset>=3.1.0 <3.1.13.1.1
PYSEC-2026-1160PyPIapache-superset<3.0.4
>=3.1.0 <3.1.1
3.0.4, 3.1.1

References

Check your stackJSON