{"cve":"CVE-2024-24773","nvd":{"published":"2024-02-28T12:15:47.477","modified":"2026-06-17T07:14:49.730","status":"Modified","description":"Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope.\nThis issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.\n\nUsers are recommended to upgrade to version 3.1.1, which fixes the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","score":6.5},"cwes":["CWE-863"],"references":["http://www.openwall.com/lists/oss-security/2024/02/28/4","https://lists.apache.org/thread/h66fy6nj41cfx07zh7l552w6dmtjh501","http://www.openwall.com/lists/oss-security/2024/02/28/4","https://lists.apache.org/thread/h66fy6nj41cfx07zh7l552w6dmtjh501"],"products":["apache:superset"],"source":"nvd","synced_at":"2026-10-19T21:45:59.823092188+00:00"},"epss":{"cve":"CVE-2024-24773","score":0.00779,"percentile":0.55924,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-5474-f7g5-273q","url":"https://osv.dev/vulnerability/GHSA-5474-f7g5-273q","summary":"Apache Superset: Improper validation of SQL statements allows for unauthorized access to data","modified":"2026-07-07T17:57:11.992856010Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":["<3.0.4"],"fixed":["3.0.4"]},{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":[">=3.1.0 <3.1.1"],"fixed":["3.1.1"]}]},{"id":"PYSEC-2026-1160","url":"https://osv.dev/vulnerability/PYSEC-2026-1160","summary":"Apache Superset: Improper validation of SQL statements allows for unauthorized access to data","modified":"2026-07-07T17:57:11.992856010Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":["<3.0.4",">=3.1.0 <3.1.1"],"fixed":["3.0.4","3.1.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}