cve.bz

CVE-2024-24772

4.3 mediumEPSS 1.0%

Medium (4.3) in apache superset. EPSS 1.0% chance of exploitation in the next 30 days. Fixed in apache-superset 3.0.4, 3.1.1.

A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.

Severity

CVSS 3.1

4.3 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
1.0% chance of exploitation in the next 30 days; higher than 61% of CVEs (scores of 2026-10-31)
CWE
CWE-89
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-m6jm-3v38-76j4PyPIapache-superset<3.0.43.0.4
GHSA-m6jm-3v38-76j4PyPIapache-superset>=3.1.0 <3.1.13.1.1
PYSEC-2026-1185PyPIapache-superset<3.0.4
>=3.1.0 <3.1.1
3.0.4, 3.1.1

References

Check your stackJSON