cve.bz

CVE-2024-23647

8.8 highEPSS 0.5%

High (8.8) in goauthentik authentik. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in goauthentik.io 2023.10.7, 2023.8.7.

Authentik is an open-source Identity Provider. There is a bug in our implementation of PKCE that allows an attacker to circumvent the protection that PKCE offers. PKCE adds the code_challenge parameter to the authorization request and adds the code_verifier parameter to the token request. Prior to 2023.8.7 and 2023.10.7, a downgrade scenario is possible: if the attacker removes the code_challenge parameter from the authorization request, authentik will not do the PKCE check. Because of this bug, an attacker can circumvent the protection PKCE offers, such as CSRF attacks and code injection attacks. Versions 2023.8.7 and 2023.10.7 fix the issue.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 45% of CVEs (scores of 2026-10-31)
CWE
CWE-287
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-mrx3-gxjx-hjqjGogoauthentik.io>=2023.10.0 <2023.10.72023.10.7
GHSA-mrx3-gxjx-hjqjGogoauthentik.io<2023.8.72023.8.7
GO-2024-2479Gogoauthentik.ioall versionsno fix published

References

Check your stackJSON