{"cve":"CVE-2024-23647","nvd":{"published":"2024-01-30T17:15:10.913","modified":"2026-06-17T07:13:18.110","status":"Modified","description":"Authentik is an open-source Identity Provider. There is a bug in our implementation of PKCE that allows an attacker to circumvent the protection that PKCE offers. PKCE adds the code_challenge parameter to the authorization request and adds the code_verifier parameter to the token request. Prior to 2023.8.7 and 2023.10.7, a downgrade scenario is possible: if the attacker removes the code_challenge parameter from the authorization request, authentik will not do the PKCE check. Because of this bug, an attacker can circumvent the protection PKCE offers, such as CSRF attacks and code injection attacks.  Versions 2023.8.7 and 2023.10.7 fix the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-287"],"references":["https://github.com/goauthentik/authentik/commit/38e04ae12720e5d81b4f7ac77997eb8d1275d31a","https://github.com/goauthentik/authentik/security/advisories/GHSA-mrx3-gxjx-hjqj","https://github.com/goauthentik/authentik/commit/38e04ae12720e5d81b4f7ac77997eb8d1275d31a","https://github.com/goauthentik/authentik/security/advisories/GHSA-mrx3-gxjx-hjqj"],"products":["goauthentik:authentik"],"source":"nvd","synced_at":"2026-10-19T21:44:57.175229480+00:00"},"epss":{"cve":"CVE-2024-23647","score":0.00549,"percentile":0.45958,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-mrx3-gxjx-hjqj","url":"https://osv.dev/vulnerability/GHSA-mrx3-gxjx-hjqj","summary":"Authentik vulnerable to PKCE downgrade attack","modified":"2026-09-10T03:50:04.988243764Z","packages":[{"ecosystem":"Go","name":"goauthentik.io","purl":"pkg:golang/goauthentik.io","ranges":[">=2023.10.0 <2023.10.7"],"fixed":["2023.10.7"]},{"ecosystem":"Go","name":"goauthentik.io","purl":"pkg:golang/goauthentik.io","ranges":["<2023.8.7"],"fixed":["2023.8.7"]}]},{"id":"GO-2024-2479","url":"https://osv.dev/vulnerability/GO-2024-2479","summary":"Authentik vulnerable to PKCE downgrade attack in goauthentik.io","modified":"2026-04-17T04:57:03.732303909Z","packages":[{"ecosystem":"Go","name":"goauthentik.io","purl":"pkg:golang/goauthentik.io","ranges":["all versions"],"fixed":[]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}