cve.bz

CVE-2023-4785

7.5 highEPSS 0.8%

High (7.5) in grpc grpc. EPSS 0.8% chance of exploitation in the next 30 days. Fixed in grpc 1.53.2, 1.54.3, 1.55.3.

Lack of error handling in the TCP server in Google's gRPC starting version 1.23 on posix-compatible platforms (ex. Linux) allows an attacker to cause a denial of service by initiating a significant number of connections with the server. Note that gRPC C++ Python, and Ruby are affected, but gRPC Java, and Go are NOT affected.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.8% chance of exploitation in the next 30 days; higher than 55% of CVEs (scores of 2026-10-31)
CWE
CWE-248
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-p25m-jpj4-qcrrRubyGemsgrpc>=1.56.0 <1.56.21.56.2
GHSA-p25m-jpj4-qcrrRubyGemsgrpc>=1.55.0 <1.55.31.55.3
GHSA-p25m-jpj4-qcrrRubyGemsgrpc>=1.54.0 <1.54.31.54.3
GHSA-p25m-jpj4-qcrrRubyGemsgrpc>=1.53.0 <1.53.21.53.2
GHSA-p25m-jpj4-qcrrPyPIgrpcio>=1.55.0 <1.55.31.55.3
GHSA-p25m-jpj4-qcrrPyPIgrpcio>=1.54.0 <1.54.31.54.3
GHSA-p25m-jpj4-qcrrPyPIgrpcio>=1.53.0 <1.53.21.53.2
PYSEC-2026-1428PyPIgrpcio>=1.55.0 <1.55.3
>=1.54.0 <1.54.3
>=1.53.0 <1.53.2
1.55.3, 1.54.3, 1.53.2

References

Check your stackJSON