{"cve":"CVE-2023-4785","nvd":{"published":"2023-09-13T17:15:10.227","modified":"2026-06-17T06:38:35.567","status":"Modified","description":"Lack of error handling in the TCP server in Google's gRPC starting version 1.23 on posix-compatible platforms (ex. Linux) allows an attacker to cause a denial of service by initiating a significant number of connections with the server. Note that gRPC C++ Python, and Ruby are affected, but gRPC Java, and Go are NOT affected.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-248"],"references":["https://github.com/grpc/grpc/pull/33656","https://github.com/grpc/grpc/pull/33667","https://github.com/grpc/grpc/pull/33669","https://github.com/grpc/grpc/pull/33670","https://github.com/grpc/grpc/pull/33672"],"products":["grpc:grpc"],"source":"nvd","synced_at":"2026-10-19T21:39:24.235896374+00:00"},"epss":{"cve":"CVE-2023-4785","score":0.00773,"percentile":0.55736,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-p25m-jpj4-qcrr","url":"https://osv.dev/vulnerability/GHSA-p25m-jpj4-qcrr","summary":"Denial of Service Vulnerability in gRPC TCP Server (Posix-compatible platforms)","modified":"2026-09-10T03:49:58.731823990Z","packages":[{"ecosystem":"RubyGems","name":"grpc","purl":"pkg:gem/grpc","ranges":[">=1.56.0 <1.56.2"],"fixed":["1.56.2"]},{"ecosystem":"RubyGems","name":"grpc","purl":"pkg:gem/grpc","ranges":[">=1.55.0 <1.55.3"],"fixed":["1.55.3"]},{"ecosystem":"RubyGems","name":"grpc","purl":"pkg:gem/grpc","ranges":[">=1.54.0 <1.54.3"],"fixed":["1.54.3"]},{"ecosystem":"RubyGems","name":"grpc","purl":"pkg:gem/grpc","ranges":[">=1.53.0 <1.53.2"],"fixed":["1.53.2"]},{"ecosystem":"PyPI","name":"grpcio","purl":"pkg:pypi/grpcio","ranges":[">=1.55.0 <1.55.3"],"fixed":["1.55.3"]},{"ecosystem":"PyPI","name":"grpcio","purl":"pkg:pypi/grpcio","ranges":[">=1.54.0 <1.54.3"],"fixed":["1.54.3"]},{"ecosystem":"PyPI","name":"grpcio","purl":"pkg:pypi/grpcio","ranges":[">=1.53.0 <1.53.2"],"fixed":["1.53.2"]}]},{"id":"PYSEC-2026-1428","url":"https://osv.dev/vulnerability/PYSEC-2026-1428","summary":"Denial of Service Vulnerability in gRPC TCP Server (Posix-compatible platforms)","modified":"2026-07-07T17:47:41.898069367Z","packages":[{"ecosystem":"PyPI","name":"grpcio","purl":"pkg:pypi/grpcio","ranges":[">=1.55.0 <1.55.3",">=1.54.0 <1.54.3",">=1.53.0 <1.53.2"],"fixed":["1.55.3","1.54.3","1.53.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}