cve.bz

CVE-2023-46604

9.8 criticalKEVEPSS 100%

The Java OpenWire protocol marshaller is vulnerable to Remote Code Execution. This vulnerability may allow a remote attacker with network access to either a Java-based OpenWire broker or client to run arbitrary shell commands by manipulating serialized class types in the OpenWire protocol to cause either the client or the broker (respectively) to instantiate any class on the classpath. Users are recommended to upgrade both brokers and clients to version 5.15.16, 5.16.7, 5.17.6, or 5.18.3 which fixes this issue.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
100% chance of exploitation in the next 30 days; higher than 99% of CVEs (scores of 2026-10-31)
CISA KEV
listed 2023-11-02, due 2023-11-23, known ransomware use
CWE
CWE-502
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-crg9-44h2-xw35Mavenorg.apache.activemq:activemq-client<5.15.165.15.16
GHSA-crg9-44h2-xw35Mavenorg.apache.activemq:activemq-client>=5.16.0 <5.16.75.16.7
GHSA-crg9-44h2-xw35Mavenorg.apache.activemq:activemq-client>=5.17.0 <5.17.65.17.6
GHSA-crg9-44h2-xw35Mavenorg.apache.activemq:activemq-client>=5.18.0 <5.18.35.18.3
GHSA-crg9-44h2-xw35Mavenorg.apache.activemq:activemq-openwire-legacy>=5.8.0 <5.15.165.15.16
GHSA-crg9-44h2-xw35Mavenorg.apache.activemq:activemq-openwire-legacy>=5.16.0 <5.16.75.16.7
GHSA-crg9-44h2-xw35Mavenorg.apache.activemq:activemq-openwire-legacy>=5.17.0 <5.17.65.17.6
GHSA-crg9-44h2-xw35Mavenorg.apache.activemq:activemq-openwire-legacy>=5.18.0 <5.18.35.18.3

References

Check your stackJSON