{"cve":"CVE-2023-46604","nvd":{"published":"2023-10-27T15:15:14.017","modified":"2026-06-17T06:31:11.370","status":"Analyzed","description":"The Java OpenWire protocol marshaller is vulnerable to Remote Code \nExecution. This vulnerability may allow a remote attacker with network \naccess to either a Java-based OpenWire broker or client to run arbitrary\n shell commands by manipulating serialized class types in the OpenWire \nprotocol to cause either the client or the broker (respectively) to \ninstantiate any class on the classpath.\n\nUsers are recommended to upgrade\n both brokers and clients to version 5.15.16, 5.16.7, 5.17.6, or 5.18.3 \nwhich fixes this issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-502"],"references":["http://seclists.org/fulldisclosure/2024/Apr/18","https://activemq.apache.org/security-advisories.data/CVE-2023-46604-announcement.txt","https://lists.debian.org/debian-lts-announce/2023/11/msg00013.html","https://packetstormsecurity.com/files/175676/Apache-ActiveMQ-Unauthenticated-Remote-Code-Execution.html","https://security.netapp.com/advisory/ntap-20231110-0010/"],"products":["apache:activemq","apache:activemq_legacy_openwire_module","debian:debian_linux","netapp:e-series_santricity_unified_manager","netapp:e-series_santricity_web_services_proxy","netapp:santricity_storage_plugin"],"source":"nvd","synced_at":"2026-10-19T21:40:11.519948003+00:00"},"epss":{"cve":"CVE-2023-46604","score":0.99992,"percentile":0.99986,"date":"2026-10-31"},"kev":{"cve":"CVE-2023-46604","date_added":"2023-11-02","due_date":"2023-11-23","vendor":"Apache","product":"ActiveMQ","known_ransomware":true},"osv":[{"id":"GHSA-crg9-44h2-xw35","url":"https://osv.dev/vulnerability/GHSA-crg9-44h2-xw35","summary":"Apache ActiveMQ is vulnerable to Remote Code Execution","modified":"2025-11-04T01:00:17.187812Z","packages":[{"ecosystem":"Maven","name":"org.apache.activemq:activemq-client","purl":"pkg:maven/org.apache.activemq/activemq-client","ranges":["<5.15.16"],"fixed":["5.15.16"]},{"ecosystem":"Maven","name":"org.apache.activemq:activemq-client","purl":"pkg:maven/org.apache.activemq/activemq-client","ranges":[">=5.16.0 <5.16.7"],"fixed":["5.16.7"]},{"ecosystem":"Maven","name":"org.apache.activemq:activemq-client","purl":"pkg:maven/org.apache.activemq/activemq-client","ranges":[">=5.17.0 <5.17.6"],"fixed":["5.17.6"]},{"ecosystem":"Maven","name":"org.apache.activemq:activemq-client","purl":"pkg:maven/org.apache.activemq/activemq-client","ranges":[">=5.18.0 <5.18.3"],"fixed":["5.18.3"]},{"ecosystem":"Maven","name":"org.apache.activemq:activemq-openwire-legacy","purl":"pkg:maven/org.apache.activemq/activemq-openwire-legacy","ranges":[">=5.8.0 <5.15.16"],"fixed":["5.15.16"]},{"ecosystem":"Maven","name":"org.apache.activemq:activemq-openwire-legacy","purl":"pkg:maven/org.apache.activemq/activemq-openwire-legacy","ranges":[">=5.16.0 <5.16.7"],"fixed":["5.16.7"]},{"ecosystem":"Maven","name":"org.apache.activemq:activemq-openwire-legacy","purl":"pkg:maven/org.apache.activemq/activemq-openwire-legacy","ranges":[">=5.17.0 <5.17.6"],"fixed":["5.17.6"]},{"ecosystem":"Maven","name":"org.apache.activemq:activemq-openwire-legacy","purl":"pkg:maven/org.apache.activemq/activemq-openwire-legacy","ranges":[">=5.18.0 <5.18.3"],"fixed":["5.18.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}