cve.bz

CVE-2023-43701

5.4 mediumEPSS 1.0%

Medium (5.4) in apache superset. EPSS 1.0% chance of exploitation in the next 30 days. Fixed in apache-superset 2.1.2.

Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code could get executed if a user specifically accesses a specific deprecated API endpoint. This issue affects Apache Superset versions prior to 2.1.2.  Users are recommended to upgrade to version 2.1.2, which fixes this issue.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
1.0% chance of exploitation in the next 30 days; higher than 62% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-wq8q-99p5-xfrwPyPIapache-superset<2.1.22.1.2
PYSEC-2026-1190PyPIapache-superset<2.1.22.1.2

References

Check your stackJSON