{"cve":"CVE-2023-43701","nvd":{"published":"2023-11-27T11:15:07.950","modified":"2026-06-17T06:26:14.150","status":"Modified","description":"Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code could get executed if a user specifically accesses a specific deprecated API endpoint. This issue affects Apache Superset versions prior to 2.1.2. \nUsers are recommended to upgrade to version 2.1.2, which fixes this issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","score":5.4},"cwes":["CWE-79"],"references":["https://lists.apache.org/thread/4dnr1knk50fw60jxkjgqj228f0xcc892","https://www.openwall.com/lists/oss-security/2023/11/27/4","https://lists.apache.org/thread/4dnr1knk50fw60jxkjgqj228f0xcc892","https://www.openwall.com/lists/oss-security/2023/11/27/4"],"products":["apache:superset"],"source":"nvd","synced_at":"2026-10-19T21:42:07.670898610+00:00"},"epss":{"cve":"CVE-2023-43701","score":0.01004,"percentile":0.62958,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-wq8q-99p5-xfrw","url":"https://osv.dev/vulnerability/GHSA-wq8q-99p5-xfrw","summary":"Apache Superset Cross-site Scripting vulnerability","modified":"2026-07-07T17:56:23.215909234Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":["<2.1.2"],"fixed":["2.1.2"]}]},{"id":"PYSEC-2026-1190","url":"https://osv.dev/vulnerability/PYSEC-2026-1190","summary":"Apache Superset Cross-site Scripting vulnerability","modified":"2026-07-07T17:56:23.215909234Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":["<2.1.2"],"fixed":["2.1.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}