cve.bz

CVE-2023-41900

4.3 mediumEPSS 0.9%

Medium (4.3). EPSS 0.9% chance of exploitation in the next 30 days. Fixed in org.eclipse.jetty:jetty-openid 10.0.16, 11.0.16, 9.4.52.v20230823.

Jetty is a Java based web server and servlet engine. Versions 9.4.21 through 9.4.51, 10.0.15, and 11.0.15 are vulnerable to weak authentication. If a Jetty `OpenIdAuthenticator` uses the optional nested `LoginService`, and that `LoginService` decides to revoke an already authenticated user, then the current request will still treat the user as authenticated. The authentication is then cleared from the session and subsequent requests will not be treated as authenticated. So a request on a previously authenticated session could be allowed to bypass authentication after it had been rejected by the `LoginService`. This impacts usages of the jetty-openid which have configured a nested `LoginService` and where that `LoginService` will is capable of rejecting previously authenticated users. Versions 9.4.52, 10.0.16, and 11.0.16 have a patch for this issue.

Severity

CVSS 3.1

4.3 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
0.9% chance of exploitation in the next 30 days; higher than 60% of CVEs (scores of 2026-10-31)
CWEs
CWE-287, CWE-1390
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pwh8-58vv-vw48Mavenorg.eclipse.jetty:jetty-openid>=9.4.21 <9.4.52.v202308239.4.52.v20230823
GHSA-pwh8-58vv-vw48Mavenorg.eclipse.jetty:jetty-openid>=10.0.0 <10.0.1610.0.16
GHSA-pwh8-58vv-vw48Mavenorg.eclipse.jetty:jetty-openid>=11.0.0 <11.0.1611.0.16

References

Check your stackJSON