{"cve":"CVE-2023-41900","nvd":{"published":"2023-09-15T21:15:11.600","modified":"2026-06-17T06:23:02.290","status":"Modified","description":"Jetty is a Java based web server and servlet engine. Versions 9.4.21 through 9.4.51, 10.0.15, and 11.0.15 are vulnerable to weak authentication. If a Jetty `OpenIdAuthenticator` uses the optional nested `LoginService`, and that `LoginService` decides to revoke an already authenticated user, then the current request will still treat the user as authenticated. The authentication is then cleared from the session and subsequent requests will not be treated as authenticated. So a request on a previously authenticated session could be allowed to bypass authentication after it had been rejected by the `LoginService`. This impacts usages of the jetty-openid which have configured a nested `LoginService` and where that `LoginService` will is capable of rejecting previously authenticated users. Versions 9.4.52, 10.0.16, and 11.0.16 have a patch for this issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","score":4.3},"cwes":["CWE-287","CWE-1390"],"references":["https://github.com/eclipse/jetty.project/pull/9528","https://github.com/eclipse/jetty.project/pull/9660","https://github.com/eclipse/jetty.project/security/advisories/GHSA-pwh8-58vv-vw48","https://security.netapp.com/advisory/ntap-20231110-0004/","https://www.debian.org/security/2023/dsa-5507"],"products":["debian:debian_linux","eclipse:jetty"],"source":"nvd","synced_at":"2026-10-19T21:39:24.235896374+00:00"},"epss":{"cve":"CVE-2023-41900","score":0.00914,"percentile":0.60105,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-pwh8-58vv-vw48","url":"https://osv.dev/vulnerability/GHSA-pwh8-58vv-vw48","summary":"Jetty's OpenId Revoked authentication allows one request","modified":"2026-09-10T03:50:03.352500057Z","packages":[{"ecosystem":"Maven","name":"org.eclipse.jetty:jetty-openid","purl":"pkg:maven/org.eclipse.jetty/jetty-openid","ranges":[">=9.4.21 <9.4.52.v20230823"],"fixed":["9.4.52.v20230823"]},{"ecosystem":"Maven","name":"org.eclipse.jetty:jetty-openid","purl":"pkg:maven/org.eclipse.jetty/jetty-openid","ranges":[">=10.0.0 <10.0.16"],"fixed":["10.0.16"]},{"ecosystem":"Maven","name":"org.eclipse.jetty:jetty-openid","purl":"pkg:maven/org.eclipse.jetty/jetty-openid","ranges":[">=11.0.0 <11.0.16"],"fixed":["11.0.16"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}