cve.bz

CVE-2023-39531

6.8 mediumEPSS 0.4%

Medium (6.8) in sentry sentry. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in sentry 23.7.2.

Sentry is an error tracking and performance monitoring platform. Starting in version 10.0.0 and prior to version 23.7.2, an attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account. Sentry SaaS customers do not need to take any action. Self-hosted installations should upgrade to version 23.7.2 or higher. There are no direct workarounds, but users should review applications authorized on their account and remove any that are no longer needed.

Severity

CVSS 3.1

6.8 medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 29% of CVEs (scores of 2026-10-31)
CWE
CWE-287
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-hgj4-h2x3-rfx4PyPIsentry>=10.0.0 <23.7.223.7.2
PYSEC-2026-1915PyPIsentry>=10.0.0 <23.7.223.7.2

References

Check your stackJSON