{"cve":"CVE-2023-39531","nvd":{"published":"2023-08-09T17:15:09.827","modified":"2026-06-17T06:12:31.983","status":"Modified","description":"Sentry is an error tracking and performance monitoring platform. Starting in version 10.0.0 and prior to version 23.7.2, an attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account. Sentry SaaS customers do not need to take any action. Self-hosted installations should upgrade to version 23.7.2 or higher. There are no direct workarounds, but users should review applications authorized on their account and remove any that are no longer needed.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N","score":6.8},"cwes":["CWE-287"],"references":["https://github.com/getsentry/sentry/security/advisories/GHSA-hgj4-h2x3-rfx4","https://github.com/getsentry/sentry/security/advisories/GHSA-hgj4-h2x3-rfx4"],"products":["sentry:sentry"],"source":"nvd","synced_at":"2026-10-19T21:39:14.809778102+00:00"},"epss":{"cve":"CVE-2023-39531","score":0.00356,"percentile":0.293,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-hgj4-h2x3-rfx4","url":"https://osv.dev/vulnerability/GHSA-hgj4-h2x3-rfx4","summary":"Sentry vulnerable to incorrect credential validation on OAuth token requests","modified":"2026-07-07T17:57:10.750983679Z","packages":[{"ecosystem":"PyPI","name":"sentry","purl":"pkg:pypi/sentry","ranges":[">=10.0.0 <23.7.2"],"fixed":["23.7.2"]}]},{"id":"PYSEC-2026-1915","url":"https://osv.dev/vulnerability/PYSEC-2026-1915","summary":"Sentry vulnerable to incorrect credential validation on OAuth token requests","modified":"2026-07-07T17:48:10.218874285Z","packages":[{"ecosystem":"PyPI","name":"sentry","purl":"pkg:pypi/sentry","ranges":[">=10.0.0 <23.7.2"],"fixed":["23.7.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}