cve.bz

CVE-2023-33966

9.8 criticalEPSS 0.6%

Critical (9.8) in deno. EPSS 0.6% chance of exploitation in the next 30 days. Fixed in deno 1.34.1.

Deno is a runtime for JavaScript and TypeScript. In deno 1.34.0 and deno_runtime 0.114.0, outbound HTTP requests made using the built-in `node:http` or `node:https` modules are incorrectly not checked against the network permission allow list (`--allow-net`). Dependencies relying on these built-in modules are subject to the vulnerability too. Users of Deno versions prior to 1.34.0 are unaffected. Deno Deploy users are unaffected. This problem has been patched in Deno v1.34.1 and deno_runtime 0.114.1 and all users are recommended to update to this version. No workaround is available for this issue.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
0.6% chance of exploitation in the next 30 days; higher than 49% of CVEs (scores of 2026-10-31)
CWEs
CWE-276, CWE-269
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-vc52-gwm3-8v2fcrates.iodeno>=1.34.0 <1.34.11.34.1
GHSA-vc52-gwm3-8v2fcrates.iodeno_runtime>=0.114.0 <0.115.00.115.0

References

Check your stackJSON