cve.bz

CVE-2023-32200

8.8 highEPSS 1.5%

High (8.8) in apache jena. EPSS 1.5% chance of exploitation in the next 30 days. Fixed in org.apache.jena:jena 4.9.0.

There is insufficient restrictions of called script functions in Apache Jena versions 4.8.0 and earlier. It allows a remote user to execute javascript via a SPARQL query. This issue affects Apache Jena: from 3.7.0 through 4.8.0.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
1.5% chance of exploitation in the next 30 days; higher than 73% of CVEs (scores of 2026-10-31)
CWE
CWE-917
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-j927-w6g7-7c7wMavenorg.apache.jena:jena>=3.7.0 <4.9.04.9.0

References

Check your stackJSON