{"cve":"CVE-2023-32200","nvd":{"published":"2023-07-12T08:15:10.070","modified":"2026-06-17T05:58:18.013","status":"Modified","description":"There is insufficient restrictions of called script functions in Apache Jena\n versions 4.8.0 and earlier. It allows a \nremote user to execute javascript via a SPARQL query.\nThis issue affects Apache Jena: from 3.7.0 through 4.8.0.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-917"],"references":["https://lists.apache.org/thread/7hg0t2kws3fyr75dl7lll8389xzzc46z","https://www.cve.org/CVERecord?id=CVE-2023-22665","https://lists.apache.org/thread/7hg0t2kws3fyr75dl7lll8389xzzc46z","https://www.cve.org/CVERecord?id=CVE-2023-22665"],"products":["apache:jena"],"source":"nvd","synced_at":"2026-10-19T21:38:30.124994567+00:00"},"epss":{"cve":"CVE-2023-32200","score":0.01473,"percentile":0.73805,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-j927-w6g7-7c7w","url":"https://osv.dev/vulnerability/GHSA-j927-w6g7-7c7w","summary":"Apache Jena Expression Language Injection vulnerability","modified":"2024-02-16T08:07:47.283644Z","packages":[{"ecosystem":"Maven","name":"org.apache.jena:jena","purl":"pkg:maven/org.apache.jena/jena","ranges":[">=3.7.0 <4.9.0"],"fixed":["4.9.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}