cve.bz

CVE-2023-32007

8.8 highEPSS 76%

High (8.8) in apache spark. EPSS 76% chance of exploitation in the next 30 days. Fixed in org.apache.spark:spark-parent_2.12 3.2.2.

** UNSUPPORTED WHEN ASSIGNED ** The Apache Spark UI offers the possibility to enable ACLs via the configuration option spark.acls.enable. With an authentication filter, this checks whether a user has access permissions to view or modify the application. If ACLs are enabled, a code path in HttpSecurityFilter can allow someone to perform impersonation by providing an arbitrary user name. A malicious user might then be able to reach a permission check function that will ultimately build a Unix shell command based on their input, and execute it. This will result in arbitrary shell command execution as the user Spark is currently running as. This issue was disclosed earlier as CVE-2022-33891, but incorrectly claimed version 3.1.3 (which has since gone EOL) would not be affected. NOTE: This vulnerability only affects products that are no longer supported by the maintainer. Users are recommended to upgrade to a supported version of Apache Spark, such as version 3.4.0.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
76% chance of exploitation in the next 30 days; higher than 99% of CVEs (scores of 2026-10-31)
CWE
CWE-77
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-59hw-j9g6-mfg3Mavenorg.apache.spark:spark-parent_2.12>=3.1.1 <3.2.23.2.2
GHSA-59hw-j9g6-mfg3PyPIpyspark>=3.1.1 <3.2.23.2.2
PYSEC-2023-72PyPIpyspark<3.2.23.2.2

References

Check your stackJSON