{"cve":"CVE-2023-32007","nvd":{"published":"2023-05-02T09:15:10.207","modified":"2026-06-17T05:57:50.193","status":"Modified","description":"** UNSUPPORTED WHEN ASSIGNED ** The Apache Spark UI offers the possibility to enable ACLs via the configuration option spark.acls.enable. With an authentication filter, this checks whether a user has access permissions to view or modify the application. If ACLs are enabled, a code path in HttpSecurityFilter can allow someone to perform impersonation by providing an arbitrary user name. A malicious user might then be able to reach a permission check function that will ultimately build a Unix shell command based on their input, and execute it. This will result in arbitrary shell command execution as the user Spark is currently running as. This issue was disclosed earlier as CVE-2022-33891, but incorrectly claimed version 3.1.3 (which has since gone EOL) would not be affected.\n\nNOTE: This vulnerability only affects products that are no longer supported by the maintainer.\n\nUsers are recommended to upgrade to a supported version of Apache Spark, such as version 3.4.0.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-77"],"references":["http://www.openwall.com/lists/oss-security/2023/05/02/1","https://lists.apache.org/thread/poxgnxhhnzz735kr1wos366l5vdbb0nv","https://spark.apache.org/security.html","https://www.cve.org/CVERecord?id=CVE-2022-33891","http://www.openwall.com/lists/oss-security/2023/05/02/1"],"products":["apache:spark"],"source":"nvd","synced_at":"2026-10-19T21:38:05.473481323+00:00"},"epss":{"cve":"CVE-2023-32007","score":0.75955,"percentile":0.99528,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-59hw-j9g6-mfg3","url":"https://osv.dev/vulnerability/GHSA-59hw-j9g6-mfg3","summary":"Apache Spark UI vulnerable to Command Injection","modified":"2026-06-09T13:04:11Z","packages":[{"ecosystem":"Maven","name":"org.apache.spark:spark-parent_2.12","purl":"pkg:maven/org.apache.spark/spark-parent_2.12","ranges":[">=3.1.1 <3.2.2"],"fixed":["3.2.2"]},{"ecosystem":"PyPI","name":"pyspark","purl":"pkg:pypi/pyspark","ranges":[">=3.1.1 <3.2.2"],"fixed":["3.2.2"]}]},{"id":"PYSEC-2023-72","url":"https://osv.dev/vulnerability/PYSEC-2023-72","summary":"","modified":"2026-06-10T17:01:44.853682289Z","packages":[{"ecosystem":"PyPI","name":"pyspark","purl":"pkg:pypi/pyspark","ranges":["<3.2.2"],"fixed":["3.2.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}