cve.bz

CVE-2023-25158

9.8 criticalEPSS 1.1%

Critical (9.8) in geotools geotools. EPSS 1.1% chance of exploitation in the next 30 days. Fixed in org.geotools:gt-jdbc 24.7, 25.7, 26.7.

GeoTools is an open source Java library that provides tools for geospatial data. GeoTools includes support for OGC Filter expression language parsing, encoding and execution against a range of datastore. SQL Injection Vulnerabilities have been found when executing OGC Filters with JDBCDataStore implementations. Users are advised to upgrade to either version 27.4 or to 28.2 to resolve this issue. Users unable to upgrade may disable `encode functions` for PostGIS DataStores or enable `prepared statements` for JDBCDataStores as a partial mitigation.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
1.1% chance of exploitation in the next 30 days; higher than 65% of CVEs (scores of 2026-10-31)
CWE
CWE-89
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-99c3-qc2q-p94mMavenorg.geotools:gt-jdbc>=28.0 <28.228.2
GHSA-99c3-qc2q-p94mMavenorg.geotools:gt-jdbc>=27.0 <27.427.4
GHSA-99c3-qc2q-p94mMavenorg.geotools:gt-jdbc>=26.0 <26.726.7
GHSA-99c3-qc2q-p94mMavenorg.geotools:gt-jdbc>=25.0 <25.725.7
GHSA-99c3-qc2q-p94mMavenorg.geotools:gt-jdbc<24.724.7

References

Check your stackJSON