cve.bz

CVE-2022-46648

8.0 highEPSS 1.4%

High (8.0). EPSS 1.4% chance of exploitation in the next 30 days. Fixed in git 1.13.0.

ruby-git versions prior to v1.13.0 allows a remote authenticated attacker to execute an arbitrary ruby code by having a user to load a repository containing a specially crafted filename to the product. This vulnerability is different from CVE-2022-47318.

Severity

CVSS 3.1

8.0 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
1.4% chance of exploitation in the next 30 days; higher than 72% of CVEs (scores of 2026-10-31)
CWE
CWE-94
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pfpr-3463-c6jhRubyGemsgit>=1.2.0 <1.13.01.13.0

References

Check your stackJSON