{"cve":"CVE-2022-46648","nvd":{"published":"2023-01-17T10:15:11.147","modified":"2026-06-17T05:12:07.473","status":"Modified","description":"ruby-git versions prior to v1.13.0 allows a remote authenticated attacker to execute an arbitrary ruby code by having a user to load a repository containing a specially crafted filename to the product. This vulnerability is different from CVE-2022-47318.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","score":8.0},"cwes":["CWE-94"],"references":["https://github.com/ruby-git/ruby-git","https://github.com/ruby-git/ruby-git/pull/602","https://jvn.jp/en/jp/JVN16765254/index.html","https://lists.debian.org/debian-lts-announce/2023/01/msg00043.html","https://github.com/ruby-git/ruby-git"],"products":["debian:debian_linux","ruby-git_project:ruby-git"],"source":"nvd","synced_at":"2026-10-19T21:37:34.931465858+00:00"},"epss":{"cve":"CVE-2022-46648","score":0.01414,"percentile":0.7273,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-pfpr-3463-c6jh","url":"https://osv.dev/vulnerability/GHSA-pfpr-3463-c6jh","summary":"ruby-git has potential remote code execution vulnerability","modified":"2025-04-04T22:13:44.318886Z","packages":[{"ecosystem":"RubyGems","name":"git","purl":"pkg:gem/git","ranges":[">=1.2.0 <1.13.0"],"fixed":["1.13.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}