cve.bz

CVE-2022-45048

8.8 highEPSS 1.1%

High (8.8) in apache ranger. EPSS 1.1% chance of exploitation in the next 30 days. Fixed in org.apache.ranger:ranger 2.4.0.

Authenticated users with appropriate privileges can create policies having expressions that can exploit code execution vulnerability. This issue affects Apache Ranger: 2.3.0. Users are recommended to update to version 2.4.0.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
1.1% chance of exploitation in the next 30 days; higher than 66% of CVEs (scores of 2026-10-31)
CWE
CWE-74
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-89gw-cffj-mqg9Mavenorg.apache.ranger:ranger>=2.3.0 <2.4.02.4.0

References

Check your stackJSON