{"cve":"CVE-2022-45048","nvd":{"published":"2023-05-05T08:15:09.080","modified":"2026-06-17T05:09:15.140","status":"Modified","description":"Authenticated users with appropriate privileges can create policies having expressions that can exploit code execution vulnerability. This issue affects Apache Ranger: 2.3.0. Users are recommended to update to version 2.4.0.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-74"],"references":["https://lists.apache.org/thread/6rpzwy1smdhr60tsh1ydknn3kdm45bb6","https://lists.apache.org/thread/6rpzwy1smdhr60tsh1ydknn3kdm45bb6"],"products":["apache:ranger"],"source":"nvd","synced_at":"2026-10-19T21:38:18.424950729+00:00"},"epss":{"cve":"CVE-2022-45048","score":0.01126,"percentile":0.6633,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-89gw-cffj-mqg9","url":"https://osv.dev/vulnerability/GHSA-89gw-cffj-mqg9","summary":"Apache Ranger code execution vulnerability in policy expressions","modified":"2023-11-08T04:10:49.772346Z","packages":[{"ecosystem":"Maven","name":"org.apache.ranger:ranger","purl":"pkg:maven/org.apache.ranger/ranger","ranges":[">=2.3.0 <2.4.0"],"fixed":["2.4.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}