CVE-2022-44729
Server-Side Request Forgery (SSRF) vulnerability in Apache Software Foundation Apache XML Graphics Batik.This issue affects Apache XML Graphics Batik: 1.16. On version 1.16, a malicious SVG could trigger loading external resources by default, causing resource consumption or in some cases even information disclosure. Users are recommended to upgrade to version 1.17 or later.
- CVSS 3.1
- 7.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H - EPSS
- 0.9% chance of exploitation in the next 30 days; higher than 60% of CVEs (scores of 2026-10-25)
- CWE
- CWE-918
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:xml_graphics_batik
- debian:debian_linux
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-gq5f-xv48-2365 | Maven | org.apache.xmlgraphics:batik-bridge | >=1.0 <1.17 | 1.17 |
| GHSA-gq5f-xv48-2365 | Maven | org.apache.xmlgraphics:batik-svgrasterizer | >=1.0 <1.17 | 1.17 |
| GHSA-gq5f-xv48-2365 | Maven | org.apache.xmlgraphics:batik-transcoder | >=1.0 <1.17 | 1.17 |