cve.bz

CVE-2022-4223

8.8 highEPSS 80%

High (8.8). EPSS 80% chance of exploitation in the next 30 days. Fixed in pgadmin4 6.17.

The pgAdmin server includes an HTTP API that is intended to be used to validate the path a user selects to external PostgreSQL utilities such as pg_dump and pg_restore. The utility is executed by the server to determine what PostgreSQL version it is from. Versions of pgAdmin prior to 6.17 failed to properly secure this API, which could allow an unauthenticated user to call it with a path of their choosing, such as a UNC path to a server they control on a Windows machine. This would cause an appropriately named executable in the target path to be executed by the pgAdmin server.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
80% chance of exploitation in the next 30 days; higher than 99% of CVEs (scores of 2026-10-31)
CWEs
CWE-862, CWE-94
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-3v6v-2x6p-32mcPyPIpgadmin4<6.176.17
PYSEC-2026-893PyPIpgadmin4<6.176.17

References

Check your stackJSON