{"cve":"CVE-2022-4223","nvd":{"published":"2022-12-13T16:15:26.277","modified":"2026-06-17T05:20:18.130","status":"Modified","description":"The pgAdmin server includes an HTTP API that is intended to be used to validate the path a user selects to external PostgreSQL utilities such as pg_dump and pg_restore. The utility is executed by the server to determine what PostgreSQL version it is from. Versions of pgAdmin prior to 6.17 failed to properly secure this API, which could allow an unauthenticated user to call it with a path of their choosing, such as a UNC path to a server they control on a Windows machine. This would cause an appropriately named executable in the target path to be executed by the pgAdmin server.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-862","CWE-94"],"references":["https://github.com/pgadmin-org/pgadmin4/issues/5593","https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/R5EYTPKHVFSDCETBJI7LBZE4EYHBPN2Q/","https://github.com/pgadmin-org/pgadmin4/issues/5593","https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/R5EYTPKHVFSDCETBJI7LBZE4EYHBPN2Q/"],"products":["fedoraproject:fedora","pgadmin:pgadmin_4"],"source":"nvd","synced_at":"2026-10-19T21:37:28.463369388+00:00"},"epss":{"cve":"CVE-2022-4223","score":0.80069,"percentile":0.99616,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-3v6v-2x6p-32mc","url":"https://osv.dev/vulnerability/GHSA-3v6v-2x6p-32mc","summary":"pgadmin4 vulnerable to Code Injection","modified":"2026-07-07T11:56:33.182394312Z","packages":[{"ecosystem":"PyPI","name":"pgadmin4","purl":"pkg:pypi/pgadmin4","ranges":["<6.17"],"fixed":["6.17"]}]},{"id":"PYSEC-2026-893","url":"https://osv.dev/vulnerability/PYSEC-2026-893","summary":"pgadmin4 vulnerable to Code Injection","modified":"2026-07-07T11:45:17.204376880Z","packages":[{"ecosystem":"PyPI","name":"pgadmin4","purl":"pkg:pypi/pgadmin4","ranges":["<6.17"],"fixed":["6.17"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}